Nodeだけではないんだろうけれど、プロジェクトに際して、パッケージの、どのバージョンが適しているのか、これがややこしい。

あたらしいバージョンは、ひんぱんにリリースされる。ならば、新しいバージョンにアップデートすれば、よろしい、というわけではない。

ニュー・バージョンのはじめは、まだ不安定なことも多いし、共同で作業をするばあいは、いちおう、同じバージョンにそろえておく必要もある。

ま、いいや。とりあえず、既存のパッケージの削除のコマンドについて、ネ。

①Package.jsonから、–save パッケージ(dependencies)を削除するばあい

npm uninstall パッケージ –save

②–save-dev パッケージ(devdependencies)を削除するばあい
(devdependenciesは、自分で作ったライブラリーを公開する場合、別のプロジェクトに利用する場合に使用)

npm uninstall パッケージ –save-dev